Latest

10 Steps to configure Cisco DSL Router

 Today I am going to talk about the easy and the simple 11 steps to configure the DSL configuration. Below is the basic setup of the DSL router in the network.

Below shown diagram is just an example of DSL connection and below is the sample configurations on the cisco routers. Let's talk about the 11 steps to configure the Cisco DSL router now.

Fig- 1.1 DSL Network Architecture


Step 1
Configure service time stamp to properly log and display debug output in the troubleshooting section.

NDNA_Router# configure terminal
NDNA_Router(config)#service timestamps debug datetime msec
NDNA_Router(config)#service timestamps log datetime msec
NDNA_Router(config)#end

Step 2
Disable the logging console on your Cisco DSL Router to suppress console messages that may be triggered while you are configuring the router.

NDNA_Router# configure terminal
NDNA_Router(config)#no logging console
NDNA_Router(config)#end

Step 3
Configure IP routing, IP subnet−zero, and ip classless to provide flexibility in routing configuration options.

NDNA_Router# configure terminal
NDNA_Router(config)#ip routing
NDNA_Router(config)#ip subnet−zero
NDNA_Router(config)#ip classless
NDNA_Router(config)#end

Step 4
Configure an IP address and subnet mask on the Cisco DSL Router Ethernet interface. Enable NAT inside on the Ethernet interface.

NDNA_Router# configure terminal
NDNA_Router(config)#interface ethernet 0
NDNA_Router(config−if)#ip address <ip address> <subnet mask>
NDNA_Router(config−if)#ip nat inside
NDNA_Router(config−if)#no shut
NDNA_Router(config−if)#end

Step 5
Configure the ATM interface of your Cisco DSL Router with an ATM permanent virtual circuit (PVC), encapsulation type, and Dialer pool.

NDNA_Router# configure terminal
NDNA_Router(config)#interface atm 0
NDNA_Router(config−if)#pvc <vpi/vci>
NDNA_Router(config−if−atm−vc)#encapsulation aal5mux ppp dialer
NDNA_Router(config−if−atm−vc)#dialer pool−member 1
NDNA_Router(config−if−atm−vc)#no shut
NDNA_Router(config−if−atm−vc)#end

Step 6
Configure the Dialer interface of your Cisco DSL Router for Point−to−Point Protocol over ATM (PPPoA) to enable a dynamic IP address to be assigned. (Optional) Enable NAT outside on the Dialer interface.

NDNA_Router# configure terminal
NDNA_Router(config)#interface dialer 1
NDNA_Router(config−if)#ip address negotiated
NDNA_Router(config−if)#no ip directed−broadcast
NDNA_Router(config−if)#ip nat outside
NDNA_Router(config−if)#encapsulation ppp
NDNA_Router(config−if)#dialer pool 1
NDNA_Router(config−if)#ppp chap hostname <username>
NDNA_Router(config−if)#ppp chap password <password>
NDNA_Router(config−if)#ppp pap sent−username <username> password <password>
NDNA_Router(config−if)#end

Step 7
Configure a default route using Dialer1 as the outbound interface.

NDNA_Router# configure terminal
NDNA_Router(config)#ip route 0.0.0.0 0.0.0.0 dialer1
NDNA_Router(config)#end

Step 8
Configure global NAT commands on the Cisco DSL Router to allow sharing of the dynamic public IP address of the Dialer interface.

NDNA_Router# configure terminal
NDNA_Router(config)#ip nat inside source list 1 interface dialer1 overload
NDNA_Router(config)#access−list 1 permit <ip address of ethernet0> <wildcard mask>
NDNA_Router(config)#end

NAT Pool, if additional IP addresses have been provided by your ISP.

NDNA_Router(config)#ip nat inside source list 1 interface dialer1 overload
NDNA_Router(config)#ip nat pool <pool name> < ip address> netmask <subnet mask>
NDNA_Router(config)#end
NDNA_Router(config)#ip nat inside source static tcp <inside ip address of server>
NDNA_Router(config)#end

Step 9
Configure the Cisco DSL Router as a DHCP server with a pool of IP addresses to assign to hosts connected to the Ethernet interface of the Cisco DSL Router. 

The DHCP server dynamically assigns an IP address, Domain Name Server (DNS), and the default gateway IP address to your hosts.

NDNA_Router# configure terminal
NDNA_Router(config)#ip dhcp excluded−address <ip address of ethernet0>
NDNA_Router(config)#ip dhcp pool <dhcp pool name>
NDNA_Router(dhcp−config)#network <ip address of ethernet0> <subnet mask>
NDNA_Router(dhcp−config)#default−router <ip address of ethernet0>
NDNA_Router(dhcp−config)#dns−server <primary dns server> <secondary dns server>
NDNA_Router(dhcp−config)#end

Step 10
Enable the logging console on the Cisco DSL Router, and write all the changes to memory.

NDNA_Router# configure terminal
NDNA_Router(config)#logging console
NDNA_Router(config)#end